As previously mentioned, DGLC strictly adheres to all Windows operating conventions - given that, please refer to your operating system's help file for information and tips on using Windows.

 

The DGLC GUI consists of a single form designed for ease of data entry and offers a logical flow of information.  Click any area on the image below (Figure 1) for additional information on it's purpose and function:

 

Figure 1 - DGLC Graphical User Interface

 

The first feature that you should be aware of is that the program always remembers it's last position on the screen and always starts there.  For example, if you have dragged DGLC to the upper, left-hand corner of your monitor and then exited the program, the next time you launch it, it will be in the upper, left-hand corner (or wherever you had it positioned).

 


FILE MENU

 

Clicking the File menu item displays a drop-down menu with two items:


OPTIONS MENU

 

Clicking the Options menu item displays a drop-down menu with two items:

Figure 2 - Decimal Settings    

 

When changing the Decimal Setting, please keep in mind that the Level Values can display a total of nine digits in any combination; therefore Decimal Settings should be changed conservatively to avoid Overflowing the Level Values display.  

 

Note: By default, the DGLC program always loads with a Decimal Setting of 3 (this setting is not saved when you exit the program) - you can change this setting at any time regardless of where you are in the calculation.  


HELP MENU

 

Clicking the Help menu item displays a drop-down menu with two items:

Figure 3 - About Dialog

 


PRICES

 

Prices are entered into their respective textboxes for each Point (A, B or C).  Entering any value other than a valid number (such as text) will generate a pop up error message.   

 

You may navigate the Prices textboxes by pressing the Tab or Enter key or by using your mouse (please refer to the Windows help file for further information on Control Navigation).  

 


DATES

 

For your convenience we've used a drop-down Calendar style control (Figure 4) for entering Dates.  Clicking the downwards facing arrow adjacent to each Date displays a Calendar that allows you to navigate from month to month to find and select a Date.  Clicking the Month Name of the Calendar displays a drop-down menu to select a given month.  Clicking the Year portion of the Calendar displays a mini-scrollbar to allow you to move forward or backwards by Year.  Clicking any Date on the Calendar loads that Date into the text area and closes the Calendar. 

 

Figure 4 - Calendar Control

 

NOTE: The DGLC program automatically excludes all weekends during the calculation. If you select a Date for a weekend, an error message will be displayed in the Error Control section of the form and the calculation will not be made.     

Calendar Keyboard Interface

The Calendar control can also be manipulated directly with the keyboard. The following table describes the different actions you can perform; you may also enter a Date manually by clicking the text area of the Calendar control and typing the Date directly.  

Key

Description
LEFT ARROW Selects the next field to the left. If this key is pressed when the left-most field is selected, the selection wraps to the right-most field.
RIGHT ARROW Selects the next field to the right. If this key is pressed when the right-most field is selected, the selection wraps to the left-most field.
UP ARROW Increments the value of the selected field.
DOWN ARROW Decrements the value of the selected field.
HOME Changes the value of the selected field to its upper limit.
END Changes the value of the selected field to its lower limit.
PLUS (+) on Numeric Keypad Increments the value of the selected field.
MINUS (-) on Numeric Keypad Decrements the value of the selected field.


The following table describes the different actions you can perform while the dropdown calendar is displayed:

 

Key

Description
LEFT ARROW Selects the next day
RIGHT ARROW Selects the previous day
UP ARROW Selects the same day of week in the previous week
DOWN ARROW Selects the same day of week in the next week
PAGE UP Scrolls the display to past months.
PAGE DOWN Scrolls the display to future months.
CTRL+PAGE UP Scrolls the display to the previous year.
CTRL+PAGE DOWN Scrolls the display to the next year.

 


PROJECTION

 

DGLC features two different methods for entering the number of days to Project into the future:

NOTE: The DGLC program uses a complex and sophisticated routine to calculate the number of business days as well as weekend exclusions.  This process is wholly dependent upon the speed of your CPU - for example, Projecting Forward 50 years may take 5 or 10 seconds on older processors.

 


LEVELS

 

DGLC Level Values are displayed in Blue when the analysis determines that ascending DGL lines are present, indicating resistance.  They are displayed in Red when the analysis determines that descending DGL lines are present, indicating support

 


  2002 - Pivot Charts International
All Rights Reserved Worldwide...